Fglrx и Ubuntu 16.04

Canonical обновила примечание к будущему релизу Ubuntu 16.04 Xenial Xerus по поводу проприетарного драйвера AMD Catalyst, известному в сообществе как fglrx.

Смысл в том, что AMD поменяла концепцию для своего драйвера. Драйвер AMD перестаёт нуждаться в своём модуле ядра, а использует всю инфраструктуру что и открытые драйвера, став набором своих реализаций OpenGL, OpenCL в пространстве пользователя.

<Здесь была картинка>

Всё это вынуждает Canonical запретить (deprecated) драйвер fglrx в будущей Убунту и предложить radeon или amdgpu. По сообщению пользователей свободный Radeon достаточно хорош в повседневной работе десктопа: просмотр видео и лёгкие игры. Следует признать, что текущая версия поддерживает только OpenGL 4.1 против доступного OpenGL 4.5. Реализация OpenCL оставляет желать лучшего.

Вариантов развития для пользователя ДВА:

Свежая установка. Разработчики рекомендуют сначала загрузиться в LiveCD и наиболее вероятно что всё пройдёт хорошо. Можно приступить к установке.
Обновление с предыдущих релизов Ubuntu 15.10 Wily Werewolf или Ubuntu 14.04 Trusty Tahr LTS. Fglrx будет удалён из системы и удалено упоминание в xorg.conf, если таковое имеется.

Новость следует понимать так, что fglrx'у никто не запрещает вообще появляться в системе. Если вы самостоятельно скачаете и поставите fglrx, проверив версии ядра linux и совместимость Xorg, то, как говорится, "флаг вам в руки". Canonical просто не будет хранить, поддерживать его в своих репозиториях и предлагать пользователю.

Полностью:
vasilisc.com

Комментарии

Изображение пользователя Crazy Rebel.

Посмотрим к чему всё это

Посмотрим к чему всё это приведёт в ближайшем будущем. А то у меня есть несколько достаточно крутых видеокарт от AMD.

style="display:inline-block;width:728px;height:15px"
data-ad-client="ca-pub-4493870272388852"
data-ad-slot="6622567932">