Установка Adobe Dreamweaver CS4 на Ubuntu Linux.

Установка Adobe Dreamweaver CS4 на Ubuntu Linux для запуска с помощью wine проходит в несколько несложных ходов. Единственное условие: Adobe Dreamweaver CS4 должен быть уже установлен на разделе с Windows.

  1. Ставим wine: $sudo apt-get install wine winecfg
  2. Из папки C:\Program Files копируем папку Adobe в /home/username/.wine/drive_c/Program Files
  3. Копируем содержимое C:\Documents and Settings\your-windows-user-name\Application Data в /home/username/.wine/drive_c/windows/profiles/All Users/Application Data/
  4. Копируем содержимое C:\Program Files\Common Files в /home/username/.wine/drive_c/Program Files/Common Files
  5. Копируем содержимое C:\WINDOWS\system32 в /home/username/.wine/drive_c/windows/system32
  6. Из C:\windows копируем папку Winsxs в /home/username/.wine/drive_c/windows/ 
  7. Импортируем файл реестра: Пуск->Выполнить->regedit, находим HKEY_LOCAL_MACHINE-> SOFTWARE->Adobe->Dreamweaver, кликаем правой клавишей на Dreamweaver‘ и выбираем Export’. Сохраняем в файл dreamweaver.reg и копируем его на раздел с Ubuntu.
  8. Для того, чтобы наш новый файл реестра поняла Ubuntu, надо перекодировать его в ASII, для этого установим программу recode: $sudo   apt-get  install  recode
  9. Перекодируем: $recode ucs-2..ascii dreamweaver.reg
  10. Импортируем файл реестра в wine: $wine regedit dreamweaver.reg
  11. Пробуем запустить Dreamweaver из под wine: $cd /home/username/.wine/drive_c/Program\ Files/Adobe/Adobe\ Dreamweaver\ CS4/   
     $wine Dreamweaver.exe

Похожая информация: Как установить и запустить Adobe Dreamweaver CS3 в Ubuntu Linux с использованием Wine

Комментарии

Изображение пользователя admin.

люди, чтож вы какие тяжёлые

люди, чтож вы какие тяжёлые то?!
ну дай ты вывод wine из терминала, ошибки, ворнинги и тд... как тебе можем помочь, если никакой информации не даешь?

Изображение пользователя doom2_imp.

У Айрата тролледетектор

У Айрата тролледетектор совсем из строя вышел =)

Вот это метод так метод!

Вот это метод так метод!

Изображение пользователя admin.

а copy/paste тоже не

а copy/paste тоже не срабатывает?

Изображение пользователя Crazy Rebel.

Гость wrote:Спасибо, хороший

Гость wrote:
Спасибо, хороший способ! Только у меня Дрим требует SP2, как в вайне подкоректировать версию ЗОСа?

winecfg, вкладка "приложения"

Изображение пользователя Crazy Rebel.

Гость wrote:Это я и так

Гость wrote:
Это я и так нашел, не ламер...
Там просто стоят операционки, но как поставить XP SP2 и выше...

Гм В поле "Версия Windows" предлагается на выбор (ну это лично у меня) версии от 2.0 до 2008, то есть выше XP там стоит 2003, Vista и 2008. Поскольку версия wine у меня не шибко новая (1.1.9) то в более новых уже и Windows7 могло появиться.

Изображение пользователя doom2_imp.

Crazy Rebel, камраду надо,

Crazy Rebel, камраду надо, чтобы wine прикинулся [b]winXP SP2[/b], не XPSP1, не вистой, не 2k или ещё чем )

Изображение пользователя doom2_imp.

> почему Дрим прекращает

> почему Дрим прекращает установку...?

так ета
[i]fixme:wininet:CommitUrlCacheEntryInternal entry already in cache - don't know what to do![/i]

Говорит, "фигня какаято, хз чё делать, пофиксите плиз" ;)

Если без шуток, то думается мне следующее:
> [i]fixme:msimtf:DllGetClassObject ({50d5107a-d278-4871-8989-f4ceaaf59cfc} {00000001-0000-0000-c000-000000000046} 0x33ca18)[/i]
Попробуй поставить последний wine, там что-то про фиксы с msi-installer были
> [i]err:ole:apartment_getclassobject DllGetClassObject returned error 0x80040111[/i]
попробуй заюзать OLE из windows, заместо вайновского (гугль в руки или тут поищи, на опенказане про это было) и вообще winetricks в руки и вперёд за удачей!

style="display:inline-block;width:728px;height:15px"
data-ad-client="ca-pub-4493870272388852"
data-ad-slot="6622567932">